POJ 3660 Cow Contest(Floyd算法的简单实现)

Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15929 Accepted: 8888

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

USACO 2008 January Silver

Source File

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 110
int win[MAXN][MAXN];
int degree[MAXN];
int main(){
    int n,m;
    while(scanf("%d %d",&n,&m)==2){
    memset(degree,0,sizeof(degree));
    memset(win,0,sizeof(win));
            for(int i=1;i<=m;i++){
                int u,v;
                scanf("%d %d",&u,&v);
                win[u][v]=1;
            }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                for(int k=1;k<=n;k++){
                    if(win[j][i]&&win[i][k])//表达这种传递思想
                        win[j][k]=1;
                }
            }
        }
        int num=0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                degree[i]+=win[i][j];
                degree[j]+=win[i][j];
            }
        }
        for(int i=1;i<=n;i++)//如果说i+j==n-1,那么就说明这个关系可以确定
            if(degree[i]==n-1) num++;
        printf("%d\n",num);
    }
}

中心思想:N个选手,如果A比B强,B比C强,则A必比C强。告知若干个强弱关系,问有多少人的排名可以确定

                  比如说,在输入的数据中,4>3,3>2,那么我们就认为4>2,其实这里面有一种传递关系的思想。

                 假如说i个人可以打败我,而我可以打败j个人,那么这个关系也就随之确定了,进行num自增操作。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值