POJ -3660 Cow Contest(Floyd)

Cow Contest

Time Limit: 1000MSMemory Limit: 65536K

Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2

题意:n头牛,m次比赛,然后m行,每行两个数a,b,表示a赢b,问有几头牛可以确定等级。
这是初始情况:("*"表示两者关系确定)

12345
1**
2*
3*
4**
5

进一步分析:

12345
1**
2*
3**
4***
5

最后我们发现:
1,3,4都在打2,而2打5, 所以2是lev.2,确定!
1,2,3,4都在打5,所以5是lev.1,确定!
可以观察到,只有当某头牛和其它n-1头牛关系都确定时,它的关系才确定。

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

const int N=1005;

int map[N][N];//map[i][j]表示i打j

int main()
{
    int n, m;
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        memset(map, 0, sizeof(map));
        int a, b;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d", &a, &b);
            map[a][b]=1;
        }
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    if(map[i][k]!=0&&map[k][j]!=0)
                        map[i][j]=1;

        int ans=0;
        for(int i=1; i<=n; i++)
        {
            int sum=0;
            for(int j=1; j<=n; j++)
                sum+=map[i][j]+map[j][i];//能不能打过都叫关系确定
            if(sum==n-1)
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值