POJ-3579 Median

Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12441 Accepted: 4354

Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

POJ Founder Monthly Contest – 2008.04.13, Lei Tao

[分析]

这道题目是关于二分查找中位数的题目,输入n个数,然后得到他们的差,将差排序之后输出中位数(中位数就是下标在中间的数)

这道题目如果强行暴力的话,那么时间复杂度直接就是n2,显然超时

于是就需要使用二分

代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000+5;
int n,a[maxn],m;
bool check(int d)
{
    int cnt=0;
    for(int i = 0; i < n; i ++)
    {
        cnt+= (upper_bound(a+i,a+n,a[i]+d)-1-(a+i));
        /*
        upper_bound,功能是在一段单调递增的序列中找到第一个大于目标元素的地址。用处是可以统计小于或等于value的元素有多少个(所以要减1)。该函数使用二分快速查找,时间性能log n。思路是对于某个确定的d,通过枚举第一个元素的下标来统计以这个元素为首的数对有多少个是满足a[j] - a[i] <= d 的,然后累加,从而计算出有多少个数对的差值是小于等于d的。记差值小于等于d的数对的个数关于d的函数为cnt(d),该函数单调递减,故使用左开右闭区间进行二分查找。
        */
    }
    if(cnt>=m) return 1;
    else  return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        int c = n*(n-1)/2;
        if(c%2==0) m = c/2;
        else  m = c/2+1;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);//输入n个数
        }
        sort(a,a+n);
        int l = -1,r = a[n-1]-a[0];
        while(r - l >1)
        {
            int mid = (r+l)/2;
            if(check(mid))  r=mid;
            else  l=mid;
        }
        printf("%d\n",r);
    }
    return 0;
}

关于lower_bound 和 upper_bound 的详细解答:https://blog.csdn.net/qq_36172505/article/details/77380559

再次提醒大家,千万不要随便用cin,会TLE

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值