[POJ3579]Median

Time Limit: 1000MS
Memory Limit: 65536K

Description

Given N numbers,X1, X2, … , XN, let us calculate the difference of every pair of numbers: XiXj(1ijN) ∣ X i − X j ∣ ( 1 ≤ i < j ≤ N ) . We can get C(N,2) C ( N , 2 ) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)th ( m / 2 ) − t h smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1,X2,...,XN,(Xi1,000,000,000) X 1 , X 2 , . . . , X N , ( X i ≤ 1 , 000 , 000 , 000 ) (3N1,00,000) ( 3 ≤ N ≤ 1 , 00 , 000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8
Source

POJ Founder Monthly Contest – 2008.04.13, Lei Tao

题意:
一个长度为100000的数列{ Xn X n },求 XiXj(1ijN) ∣ X i − X j ∣ ( 1 ≤ i < j ≤ N ) 的中位数
题目种可能没讲清楚,如果 n(n1)/2 n ∗ ( n − 1 ) / 2 是偶数的话,那么中位数是第 n(n1)/4 n ∗ ( n − 1 ) / 4 小的数字否则中位数是第 n(n1)/4+1 n ∗ ( n − 1 ) / 4 + 1 小的数字
题解:
先将数列{ Xn X n }排序。
我们只需要二分这个中位数ANS是多少,然后判断有多少个数字比他小就好了。但是由于在中位数周围会出现相同数字连在一起的情况,那么我们就二分ANS+1就好了。对于确定的Xi,判断所有 XjXi(j>i) X j − X i ( j > i ) 有多少个数字比ANS+1小,只要从 j[i+1,n] j ∈ [ i + 1 , n ] ,二分出一个最大的j使得 Xj<Xi+ANS+1 X j < X i + A N S + 1 就好了,就可以快速统计 Xj<Xi+ANS+1 X j < X i + A N S + 1 的数量。
然后答案就是ANS

#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<cstdio>
#define LiangJiaJun main
#define ll long long
#define eps (1e-6)
using namespace std;
int n,k,a[100004];
ll lim;
ll  calc(int l,int r,int x){
    ll mid,st=-1,bg=l;
    while(l<=r){
        mid=(l+r)>>1;
        if(a[mid]<x){
            st=mid;
            l=mid+1;
        }
        else r=mid-1;
    }
    if(st==-1)return 0;
    return st-bg+1;
}
ll  check(int x){
    ll sum=0;
    for(int i=1;i<=n;i++){
        sum+=calc(i+1,n,a[i]+x);
    }
    return sum;
}
int w33ha(){
    for(int i=1;i<=n;i++)scanf("%d",&a[i]);
    sort(a+1,a+n+1);
    lim=(1LL*n)*(n-1LL)/2;
    if(lim&1)lim=lim/2+1;
    else lim/=2;
    ll mid,L=0,R=a[n]-a[1],ans=-1;
    while(L<=R){
        mid=(L+R)>>1;
        if(lim<=check(mid)){
            ans=mid;
            R=mid-1;
        }
        else L=mid+1;
    }
    printf("%d\n",ans-1);
    return 0;
}
int LiangJiaJun (){
    while(scanf("%d",&n)!=EOF)w33ha();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值