UVA 11384 Help is needed for Dexter (递归函数)

题目链接

https://vjudge.net/problem/26096/origin

题目

Dexter is tired of Dee Dee. So he decided to keep Dee Dee busy in a game. The game he planned for her is quite easy to play but not easy to win at least not for Dee Dee. But Dexter does not have time to spend on this silly task, so he wants your help.
There will be a button, when it will be pushed a random number N will be chosen by computer. Then on screen there will be numbers from 1 to N. Dee Dee can choose any number of numbers from the numbers on the screen, and then she will command computer to subtract a positive number chosen by her (not necessarily on screen) from the selected numbers. Her objective will be to make all the numbers 0.
Now she subtracts 2 from 2 and all the numbers become 0. Dexter is not so dumb to understand that this can be done very easily, so to make a twist he will give a limit L for each N and surely L will be as minimum as possible so that it is still possible to win within L moves.
But Dexter does not have time to think how to determine L for each N, so he asks you to write a code which will take N as input and give L as output.

Input

##
Input consists of several lines each with N such that 1 ≤ N ≤ 1,000,000,000. Input will be terminated by end of file.

Output

For each N output L in separate lines.

Sample Input

1 2 3

Sample Output

1 2 2


题意

给定一个正整数序列,每次可以从序列中选一个或多个数减去一个正整数。要使序列最终的值都为0,问最少的操作数为多少?


题解

对于每个不同的值x,显然可以通过减去x使得它的值最终为0.初始序列有n个不同的值,所以这种方法需要操作数为n。
要想办法减少操作数,就要通过操作将序列中的值尽可能的变成相同。
对于有n个数的序列,将[n/2+1,n]中的数都减去n/2+1,这样就使得不同的值只在[1,n/2]内。通过一次操作减少了n/2次操作。
所以,F(N)=F(N/2)+1.

代码

#include <cstdio>

using namespace std;

int f(int n)
{
    if(n==1) return 1;
    return f(n/2)+1;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        printf("%d\n",f(n));

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值