Open Credit System UVA - 11078

题目

In an open credit system, the students can choose any course they like, but there is a problem. Some
of the students are more senior than other students. The professor of such a course has found quite a
number of such students who came from senior classes (as if they came to attend the pre requisite course
after passing an advanced course). But he wants to do justice to the new students. So, he is going to
take a placement test (basically an IQ test) to assess the level of difference among the students. He
wants to know the maximum amount of score that a senior student gets more than any junior student.
For example, if a senior student gets 80 and a junior student gets 70, then this amount is 10. Be careful
that we don’t want the absolute value. Help the professor to figure out a solution.

Input

Input consists of a number of test cases T (less than 20). Each case starts with an integer n which is
the number of students in the course. This value can be as large as 100,000 and as low as 2. Next n
lines contain n integers where the i’th integer is the score of the i’th student. All these integers have
absolute values less than 150000. If i < j, then i’th student is senior to the j’th student.

Output

For each test case, output the desired number in a new line. Follow the format shown in sample
input-output section.

Sample Input

3
2
100
20
4
4
3
2
1
4
1
2
3
4

Sample Output

80
3
-1

题意

给定一个整数序列a[0]、a[1]、a[2]…a[n-1].求a[i]-a[j]的最大值,其中i小于j.

分析

如果通过两层循环遍历求最大值,时间复杂度为O(n*n).而n的最大值为1e5,肯定会超时。

对于固定的j,我们要选i小于j且a[i]的值最大的i。所以,我们可以枚举j并维护a[i]。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;

int n,largest,ans;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int x;
        scanf("%d",&x);
        ans=-INF;
        largest=x;
        for(int i=1;i<n;i++)
        {

            scanf("%d",&x);
            ans=max(ans,largest-x);
            largest=max(largest,x);
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于微信小程序的家政服务预约系统采用PHP语言和微信小程序技术,数据库采用Mysql,运行软件为微信开发者工具。本系统实现了管理员和客户、员工三个角色的功能。管理员的功能为客户管理、员工管理、家政服务管理、服务预约管理、员工风采管理、客户需求管理、接单管理等。客户的功能为查看家政服务进行预约和发布自己的需求以及管理预约信息和接单信息等。员工可以查看预约信息和进行接单。本系统实现了网上预约家政服务的流程化管理,可以帮助工作人员的管理工作和帮助客户查询家政服务的相关信息,改变了客户找家政服务的方式,提高了预约家政服务的效率。 本系统是针对网上预约家政服务开发的工作管理系统,包括到所有的工作内容。可以使网上预约家政服务的工作合理化和流程化。本系统包括手机端设计和电脑端设计,有界面和数据库。本系统的使用角色分为管理员和客户、员工三个身份。管理员可以管理系统里的所有信息。员工可以发布服务信息和查询客户的需求进行接单。客户可以发布需求和预约家政服务以及管理预约信息、接单信息。 本功能可以实现家政服务信息的查询和删除,管理员添加家政服务信息功能填写正确的信息就可以实现家政服务信息的添加,点击家政服务信息管理功能可以看到基于微信小程序的家政服务预约系统里所有家政服务的信息,在添加家政服务信息的界面里需要填写标题信息,当信息填写不正确就会造成家政服务信息添加失败。员工风采信息可以使客户更好的了解员工。员工风采信息管理的流程为,管理员点击员工风采信息管理功能,查看员工风采信息,点击员工风采信息添加功能,输入员工风采信息然后点击提交按钮就可以完成员工风采信息的添加。客户需求信息关系着客户的家政服务预约,管理员可以查询和修改客户需求信息,还可以查看客户需求的添加时间。接单信息属于本系统里的核心数据,管理员可以对接单的信息进行查询。本功能设计的目的可以使家政服务进行及时的安排。管理员可以查询员工信息,可以进行修改删除。 客户可以查看自己的预约和修改自己的资料并发布需求以及管理接单信息等。 在首页里可以看到管理员添加和管理的信息,客户可以在首页里进行家政服务的预约和公司介绍信息的了解。 员工可以查询客户需求进行接单以及管理家政服务信息和留言信息、收藏信息等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值