UVA Open Credit System 11078 (技巧求区间最大值) 好题

Open Credit System

In an open credit system, the students can choose any course they like, but there is a problem. Someof the students are more senior than other students. The professor of such a course has found quite anumber of such students who came from senior classes (as if they came to attend the pre requisite courseafter passing an advanced course). But he wants to do justice to the new students. So, he is going totake a placement test (basically an IQ test) to assess the level of difference among the students. Hewants to know the maximum amount of score that a senior student gets more than any junior student.For example, if a senior student gets 80 and a junior student gets 70, then this amount is 10. Be carefulthat we don’t want the absolute value. Help the professor to figure out a solution.

Input

Input consists of a number of test cases T (less than 20). Each case starts with an integer n which isthe number of students in the course. This value can be as large as 100,000 and as low as 2. Next nlines contain n integers where the i’th integer is the score of the i’th student. All these integers haveabsolute values less than 150000. If i < j, then i’th student is senior to the j’th student.

Output

For each test case, output the desired number in a new line. Follow the format shown in sampleinput-output section.

Sample Input

3

2

100

20

4

4

3

2

1

4

1

2

3

4

Sample Output

80

3

-1

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
#define INF 0x3f3f3f3f
#define N 100010
using namespace std;
int a[N];
int main()
{
	int t,n,m,i,j;
	scanf("%d",&t);
	while(t--)
	{	
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		int ans=a[0]-a[1];
		int mm=a[0];
		for(i=1;i<n;i++)
		{
			ans=max(ans,mm-a[i]);
			mm=max(a[i],mm);
		}
		printf("%d\n",ans);
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值