【JAVA大数】Hat's Fibonacci HDU - 1250

题目链接

Hat’s Fibonacci HDU - 1250

题目

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

题意

给定一个递推公式,要求求第n位的指。值的位数不超过2005位。

分析

递推,O(n)级别算法,时间肯定不会超限。
然后调用JAVA的BigInteger包来解决大数问题就好了。

AC代码

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int n;
        while(cin.hasNext()) {
            n=cin.nextInt();
            BigInteger a,b,c,d,e;
            a=BigInteger.ONE;
            b=c=d=e=a;
            for(int i=5;i<=n;i++) {
                e=a.add(b).add(c).add(d);
                a=b;
                b=c;
                c=d;
                d=e;
            }
            System.out.println(e);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值