HDU 1250 Hat's Fibonacci



Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8372    Accepted Submission(s): 2725


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

Author
戴帽子的


滚动数组+大数。
开个二维数组,第一维是N,第二维是数字个数。。
#include <stdio.h>
#include <algorithm>
#include<iostream>
#include<cstring>
using namespace std;
#include <string.h>
int main()
{
	int x[5][2008]; //之所以开5,因为下面所有的操作都MOD 5 了。
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		if(n<=4)
		{
			printf("1\n");
			continue;
		}
		memset(x,0,sizeof(x));
		x[1][0]=1;
		x[2][0]=1;
		x[3][0]=1;
		x[4][0]=1;      //初始化
		for(i=5;i<=n;i++)
		{
			memset(x[i%5],0,sizeof(x[i%5]));  //初始化。
			for(j=0;j<=2005;j++)
			{
				x[i%5][j]+=x[(i-1)%5][j]+x[(i-2)%5][j]+x[(i-3)%5][j]+x[(i-4)%5][j];//大数思想+滚动数组
				if(x[i%5][j]>=10)  
				{
					x[i%5][j+1]+=x[i%5][j]/10;   //因为是反过来输出,所以要后一位进位。
					x[i%5][j]%=10;
				}
			}
		}
		i=2005;
		while(x[n%5][i]==0)//从后面开始判断非0。
			--i;
		while(i>=0)
		{
			printf("%d",x[n%5][i]); //一个数一个数输出。
			--i;
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值