Prime Ring Problem

题目链接
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
这里写图片描述
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int n, dis[20];
bool visited[20];
bool is_Prime(int a){
    for(int i = 2; i <= sqrt(a); i++)
        if(a % i == 0)
            return false;
    return true;
}
void dfs(int a){
    if(a == n && is_Prime(1+dis[n-1])){//如果到达结尾,并且最后一个数和第一个数1能够构成素数
        for(int i = 0; i < n; i++){
            if(!i)
                cout<<dis[i];
            else
                cout<<" "<<dis[i];
        }
        cout<<endl;
        return;
    }
    else
        for(int i = 2; i <= n; i++)
            if(!visited[i] && is_Prime(i+dis[a-1])){
                visited[i] = true;
                dis[a] = i;
                dfs(a + 1);
                visited[i] = false;
            }
}
int main(){
    int sign = 1;
    while(cin>>n){
        cout<<"Case "<<sign++<<":"<<endl;
        if(n == 1){//一个数字也可以构成环
            cout<<"1"<<endl;
            continue;
        }
        if(n&1){//&1的结果就是取二进制的最末位t,t==1是奇数,t==0为偶数
            /*
                奇数不行的原因是:
                    1.奇数+奇数 = 偶数(不是质数)
                    2.奇数+偶数 = 奇数(不能确定是否是质数)
                    3.偶数+偶数 = 偶数(不是质数)
                ps:如果n是奇数的话,定会导致奇数的个数比偶数的个数多一个
                   换句话说,只有奇数和偶数一一对应的时候,才有可能出现质数,即奇数的个数==偶数的个数
            */
            cout<<"No Answer"<<endl;
            continue;
        }
        dis[0] = 1;
        memset(visited,false, sizeof(visited));
        dfs(1);
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值