A sequence of numbers

题目链接
Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
Output
Output one line for each test case, that is, the K-th number module (%) 200907.
Sample Input
2
1 2 3 5
1 2 4 5
Sample Output
5
16
注意点:
1.关于理解上的偏差,arithmetic or geometric sequences这句话的本义是序列是算术序列
   或者几何序列,其实就是等差数列和等比数列
2.等比数列的同余定理加快速幂的算法,点击此处
3.等差数列的同余定理 (a + b) mod c = (a mod c + b mod c) mod c;证明的话,大家可以自行百度,这里不在赘述
4.因为数比较大,所以使用long long 类型

#include<iostream>
#include<cstdio>
using namespace std;
long long ff(long long x,long long y){
    long long ans = 1;
    x = x % 200907;
    while(y>0){
        if(y&1)
            ans = ans * x % 200907;
        y>>=1;
        x = x * x % 200907;
    }
    return ans;
}
int main(){
    int n;
    scanf("%d",&n);
    while(n--){
        long long x, y, z, k, ans;
        scanf("%lld%lld%lld%lld",&x,&y,&z,&k);
        if(z-y==y-x)
            ans = (x % 200907 + (((k-1) % 200907) * (y-x) % 200907) % 200907)%200907;
        else{
            long long q = y/x;
            long long result_of = ff(q,k-1);
            ans = ((x % 200907)*(result_of%200907)) % 200907;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值