搜索--H

H - 08
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


思路就是1       1+10       1+10+1    加出来的两个分别+10    +10+1    以此类推    类似于二叉树

#include <cstdlib>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <map>
#include <string>
#include <algorithm> 
using namespace std;
unsigned long long answer;
int dfs(unsigned long long prenum,unsigned long long lev,int n)
{
    if(prenum>=lev) 
    return 0;   
    if(lev%n==0)
    {answer=lev;return 1;}    
    if(dfs(lev,lev*10,n))    
	{return 1;}     
    return dfs(lev,lev*10+1,n);     
}
int main()
{
    int n;
    int i,j,k;     
    while(scanf("%d",&n)!=EOF)
    {
         if(!n)
				break;
         if(dfs(0,1,n))
				cout<<answer<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值