Distinct Values hdu

Problem Description

Chiaki has an array of n positive integers. You are told some facts about the array: for every two elements ai and aj in the subarray al..r (l≤i<j≤r), ai≠ajholds.
Chiaki would like to find a lexicographically minimal array which meets the facts.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers n and m (1≤n,m≤105) -- the length of the array and the number of facts. Each of the next m lines contains two integers li and ri (1≤li≤ri≤n).
It is guaranteed that neither the sum of all n nor the sum of all m exceeds 106.

Output

For each test case, output n integers denoting the lexicographically minimal array. Integers should be separated by a single space, and no extra spaces are allowed at the end of lines.

Sample Input

3 2 1 1 2 4 2 1 2 3 4 5 2 1 3 2 4

Sample Output

1 2 1 2 1 2 1 2 3 1 1

题目:n个整数的序列,给你m个条件,条件中给出l,r  意思是在序列中【l,r】中任意两数都不相同,问最后最小的这n个数。
思路:区间排序加贪心,里面用优先队列维护区间中的值
代码:
#include<bits/stdc++.h>
using namespace std;
int a[100005];
struct node
{
    int date;
    bool operator<(const node &aa)const
    {
        return date>aa.date;
    }
};
priority_queue<node>q;
struct line
{
    int u,to;
    bool operator<(const line &aa)
    {
        if(u!=aa.u)
        return u<aa.u;
        return to<aa.to;
    }
}v[200005];
int main()
{
    int t,i,j,str,n,m,l;
    node now;
    scanf("%d",&t);
    while(t--)
    {
        while(!q.empty())
        {
            q.pop();
        }
        scanf("%d%d",&n,&m);
        str=1;
        for(i=0;i<m;i++)
            scanf("%d%d",&v[i].u,&v[i].to);
        for(j=i,i=1;i<=n;i++,j++)
            v[j].u=v[j].to=i;
        m=j;
        sort(v,v+m);
        for(i=0,j=0,l=0;i<m&&j<n;i++)
        {
           // printf("aaaa %d %d\n",l,v[i].u);
            while(l<v[i].u-1)
            {
                now.date=a[l];
                q.push(now);
                l++;
            }
            while(j<v[i].to)
            {
                if(q.empty())
                {
                    //printf("ssss  %d %d\n",j,str);
                    a[j++]=str;
                    str++;
                }
                else
                {
                    //printf("ok  %d %d\n",j,str);
                    now=q.top();
                    a[j++]=now.date;
                    q.pop();
                }
            }

        }
        printf("%d",a[0]);
        for(i=1;i<n;i++)
        printf(" %d",a[i]);
        printf("\n");

    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值