1588:Kickdown

45 篇文章 0 订阅
44 篇文章 0 订阅
Kickdown
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2214 Accepted: 944

Description

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

There are two lines in the input file, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output

Write a single integer number to the output file — the minimal length of the stripe required to cut off given sections.

Sample Input

sample input #1
2112112112
2212112

sample input #2
12121212
21212121

sample input #3
2211221122
21212

Sample Output

sample output #1
10

sample output #2
8

sample output #3
15

Source

Northeastern Europe 2006

我的代码,一定要注意左移右移都要试一下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100 + 5;
int main(){
    char* bot = new char[maxn];
    char* top = new char[maxn];
    while(scanf("%s %s",top,bot) == 2){
        int minLl,minLr,i,j,botl = strlen(bot),topl = strlen(top);
        //右移最小长度
        for(i = 0;i < botl;i++){
            for(j = 0;top[j];j++){
                if(i + j < botl && bot[i+j] + top[j] - '0' - '0' > 3) break;
            }
            if(!top[j]){
                minLl = max(botl,i + j);
                break;
            }
        }
        if(i >= botl) minLl = botl + topl;
        //左移最小长度
        for(i = 0;i < topl;i++){
            for(j = 0;bot[j];j++){
                if(i + j < topl && top[i+j] + bot[j] - '0' - '0' > 3) break;
            }
            if(!bot[j]){
                minLr = max(topl,i + j);
                break;
            }
        }
        if(i >= topl) minLr = botl + topl;
        printf("%d\n",min(minLl,minLr));
        memset(bot,0,sizeof(bot));
        memset(top,0,sizeof(top));
    }
    return 0;
}

我的运行时间使32ms,这位博主的代码是0ms,也更简洁,如下:

#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
#include <math.h>  
  
const int maxn = 110;  
const int THREE = 3+'0'+'0';  
char bot[maxn];  
char top[maxn];  
  
int length(char* bot,char* top)  
{  
    int len = strlen(bot);  
    int len1 = strlen(top);  
    int sum = len + len1;  
    for(int i=0; i<len; i++)  
    {  
        char* b = bot+i;  
        char* t = top;  
        while(*b && *t)  
        {  
            if(*b+*t<=THREE){b++;t++;}  
            else break;  
        }  
        if(!*b || !*t)  
        {  
            if(len-i>len1)sum-=len1;  
            else sum-=(len-i);  
            break;  
        }  
    }  
    return sum;  
}  
  
int main()  
{  
    while(~scanf("%s%s",bot,top))  
    {  
        int sum1 = length(bot,top);  
        int sum2 = length(top,bot);  
        printf("%d\n",sum1<sum2?sum1:sum2);  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值