133:The Dole Queue

16 篇文章 0 订阅
The Dole Queue 

Time limit: 3.000 seconds

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

 

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

 

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

 

Sample input

 

10 4 3
0 0 0

 

Sample output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7


这道题看起来挺简单的,就直接去模拟就行,但是写的时候还是遇到了不少问题,这是最初的代码,超时。。。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 21;
int choosen[maxn];
int main(){
    int n,k,m;
    while((scanf("%d %d %d",&n,&k,&m)) == 3 && n){
        int left = n,a = 0,b = n+1;
        choosen[0] = 1;
        while(left){
            int cnt = 0;
            while(cnt < k){
                a++;
                if(!choosen[a % (n+1)]) cnt++;
            }
            int ac = a % (n+1);
            left--;
            printf("%3d",ac);
            cnt = 0;
            while(cnt < m){
                if(b == 1) b = 11;
                b--;
                if(!choosen[b]) cnt++;
            }
            if(b != ac){
                left--;
                choosen[b] = 1;
                printf("%3d",b);
            }
            choosen[ac] = 1;
            !left ? putchar('\n') : putchar(',');
        }
    }
    return 0;
}

应该是这段循环的问题:

            while(cnt < k){
                a++;
                if(!choosen[a % (n+1)]) cnt++;
            }
每次改变 a 都要判断两次,可以将里面换成一个循环,这样 cnt 只需要判断 k 次,同时每次改变 a 后都立即取余,否则 a 很大的时候计算余数应该也很浪费时间,修改如下,顺利AC。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 21;
int choosen[maxn];
int main(){
    int n,k,m;
    while((scanf("%d %d %d",&n,&k,&m)) == 3 && n){
        int left = n,a = 0,b = n+1;
        memset(choosen,0,sizeof(choosen));
        choosen[0] = 1;
        while(left){
            int cnt = k;
            while(cnt--){
                do{
                    a = (a+1) % (n+1);
                }while(choosen[a]);
            }
            left--;
            printf("%3d",a);
            cnt = m;
            while(cnt--){
                do{
                    if(b == 1) b = n + 1;
                    b--;
                }while(choosen[b]);
            }
            if(b != a){
                left--;
                choosen[b] = 1;
                printf("%3d",b);
            }
            choosen[a] = 1;
            !left ? putchar('\n') : putchar(',');
        }
    }
    return 0;
}

这是刘汝佳的代码,其中主要的不同就是如何将 b 从 1 转化成 n,书上是这样解决的:

 p = (p + d + n-1)%n + 1
对于 a 没影响,对于 b 的话每次为 1 的话就会转换为 n +1,不用每次都去判断,非常巧妙。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 21;
int n,k,m,choosen[maxn];
int go(int p,int d,int t){
    while(t--){
        do{
            p = (p + d + n-1)%n + 1;//这个地方很巧妙
        }while(choosen[p] == 0);
    }
    return p;
}
int main(){
    while((scanf("%d %d %d",&n,&k,&m)) == 3 && n){
        int left = n,a = n, b = 1;
        for(int i = 1;i <= n;i++){
            choosen[i] = i;
        }
        while(left){
            a = go(a,1,k);
            b = go(b,-1,m);
            choosen[a] = 0;
            left--;
            printf("%3d",a);
            if(b != a){
                choosen[b] = 0;
                left--;
                printf("%3d",b);
            }
            if(left) putchar(',');
        }
        putchar('\n');
    }
    return 0;
}

用C++编写程序,实现以下问题2、题目ID Codes(POJ1146) Time Limit: 1000MS Memory Limit: 10000K 描述: It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 of b' and 1 of c', then three of the allowable 60 codes under these conditions are: abaabc abaacb ababac These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message No Successor' if the given code is the last in the sequence for that set of characters. 输入: Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. 输出: Output will consist of one line for each code read containing the successor code or the words 'No Successor'. 样例输入 abaacb cbbaa # 样例输出 ababac No Successor
最新发布
05-22
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值