HDU-1011-Starship Troopers

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20832    Accepted Submission(s): 5549


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7

题意:你是舰队的舰长,然后去消灭敌人,敌人藏在一些洞里面,因为要擒贼先擒王嘛,所以我们要捕获敌人的领导者大脑,每个房间有一些虫子(电影中的虫族?=。=),消灭需要1士兵/20虫子,每个房间都给你有大脑的概率,然后让你求在士兵消耗完之前怎么走使得最后得到的概率最大。简单来说就是一棵树,给你一定的费用,每到一个点会消耗20费用,同时会获得一定的价值,然后求最大所能获得的价值。

状态转移:dp[now][i]=max(dp[now][i],dp[now][i-k]+dp[son][k]),当前点所能获得的最大价值为当前消耗k个士兵所能获得的最大价值。

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;
int n,m;
struct f
{
int cz,mt;
}mapp[105];
int dp[105][105];
bool bj[105];
int tree[105][105];
void dfs(int p)
{
bj[p]=true;
int s=mapp[p].cz/20;
double x=mapp[p].cz/20.0;
if(x!=s)
    s++;
for(int i=s;i<=m;i++)  dp[p][i]=mapp[p].mt;
    for(int i=1;i<=tree[p][0];i++)
        {
        int pp=tree[p][i];
        if(bj[pp])
            continue;
        dfs(pp);
        for(int j=m;j>=s;j--)
            for(int k=1;j+k<=m;k++)
                if(dp[pp][k])
                  dp[p][j+k]=max(dp[p][j+k],dp[p][j]+dp[pp][k]);
        }
}
int main()
{
int a,b;
while(cin>>n>>m)
    {
    memset(dp,0,sizeof(dp));
    memset(tree,0,sizeof(tree));
    memset(bj,false,sizeof(bj));
    if(n==-1&&m==-1)
        break;
    for(int i=1;i<=n;i++)
        scanf("%d%d",&mapp[i].cz,&mapp[i].mt);
    for(int i=1;i<n;i++)
        {
        scanf("%d%d",&a,&b);
        tree[a][0]++;
        tree[a][tree[a][0]]=b;
        tree[b][0]++;
        tree[b][tree[b][0]]=a;
        }
    if(m==0)
        cout<<0<<endl;
    else
        {
        dfs(1);
        cout<<dp[1][m]<<endl;
        }
    }
return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值