杭电5443 The Water Problem

题目链接:这里写链接内容
Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,…,an representing the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.

Input
First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,…,an, and each integer is in {1,…,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

Output
For each query, output an integer representing the size of the biggest water source.

Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3

Sample Output
100
2
3
4
4
5
1
999999
999999
1

区间最值查询问题,直接上st。

#include<iostream>
#include<cstdio>

const int N=1008;
int a[N],stmax[N][N],log[N];
int n;
using namespace std;

void init() {
	log[0]=-1;
	for(int i=1; i<=1000; i++) {
		log[i]=log[i/2]+1;

	}
	for(int i=1; i<=n; i++) {
		stmax[0][i]=a[i];
	}
	for(int i=1; i<=log[n]; i++) {
		for(int j=1; j+(1<<i)-1<=n; j++) {
			stmax[i][j]=max(stmax[i-1][j],stmax[i-1][j+(1<<(i-1))]);
		}
	}

}
int rmq_max(int l,int r) {
	int t=log[r-l+1];//2^log[len]>len/2;
	return max(stmax[t][l],stmax[t][r-(1<<t)+1]);
}
int main() {
	int t;
	scanf("%d",&t);
	while(t--) {
	scanf("%d",&n);
	for(int i=1; i<=n; i++) {
		scanf("%d",&a[i]);
	}
	init();
	int q;
	scanf("%d",&q);
	while(q--) {
	int l,r;
	scanf("%d%d",&l,&r);
	printf("%d\n",rmq_max(l,r));
		}
	}


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值