The Water Problem

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a 1 , a 2 , a 3 , . . . . . . , a n a_{1},a_{2},a_{3},......,a_{n} a1,a2,a3,......,an representing the size of the water source. Given a set of queries each containing 2 integers l and r,please find out the biggest water source between a l a_l al and a r a_r ar.
Input
First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a 1 , a 2 , a 3 , . . . . . . , a n a_{1},a_{2},a_{3},......,a_{n} a1,a2,a3,......,an, and each integer is in {1,…,10e6}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.
Output
For each query, output an integer representing the size of the biggest water source.
Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3
Sample Output
100
2
3
4
4
5
1
999999
999999
1

分析

ST算法
𝑅𝑀𝑄 问题。ST 算法模板题。预处理时间 𝑂(𝑛𝑙𝑜𝑔𝑛),查询时间 𝑂(1)。

import java.io.BufferedInputStream;
import java.io.IOException;
import java.util.Scanner;

public class Main{
	static int N=(int)1e3+5,n,m,k;
	static int a[]=new int [N];
	static int f[][]=new int [N][11];
	
	public static void main(String[] args)throws IOException {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int x,y;
		int t=sc.nextInt();
		while(t-->0) {
			n=sc.nextInt();
			for(int i=1;i<=n;i++) a[i]=sc.nextInt();
			st_prework();
			m=sc.nextInt();
			while(m-->0) {
				x=sc.nextInt();y=sc.nextInt();
				System.out.println(st_query(x,y));
			}
		}
	}
	static void st_prework() {
		for(int i=1;i<=n;i++) f[i][0]=a[i];
		int t=(int)(Math.log(n)/Math.log(2)+1);
		for(int j=1;j<t;j++)
			for(int i=1;i<=n-(1<<j)+1;i++)
				f[i][j]=Math.max(f[i][j-1], f[i+(1<<j-1)][j-1]);
	}
	static int st_query(int l,int r) {
		int k=(int)(Math.log(r-l+1)/Math.log(2));
		return Math.max(f[l][k], f[r-(1<<k)+1][k]);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值