poj2503 Babelfish(map,二分)

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.
 

这个英文不难看懂,题也比较水,把它放到博客上的原因只是为了复习下map的用法

map版代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<map>

const int MAXN=100005;
using namespace std;
map<string,string> dic;
string t1,t2; char f;
//这道题让我先用map水过去,哈哈哈哈
int main()
{
    while(true)
    {
        cin>>t1;
        f=getchar();
        if(f=='\r'||f=='\n') break;
        cin>>t2;
        dic[t2]=t1;
    }
    if(dic.count(t1)) cout<<dic[t1]<<endl;
    else printf("eh\n");
    while(cin>>t1)
    {
        if(dic.count(t1)) cout<<dic[t1]<<endl;
        else printf("eh\n");
    }
}

超级短,所以二分的代码以后来补啦~

说个思路:对于当地的单词按字典序排序,并且在排序之前记录一个标号来对应自己的语言,然后就二分查找啦~


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值