C++ 字典问题 map和sscanf的使用

13 篇文章 1 订阅

Babelfish

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

整体来说,问题用map解决,但本题的关键在于输入结束条件的控制。参考了uva 10282 Babelfish(STL map),先获得字符数组,再判断字符数组首个字符是否为回车,如果不是则用sscanf()函数输入。

#include <iostream>
#include <stdio.h>
#include<stdlib.h>
#include<map>
using namespace std;

int main()
{
    map<string,string>mp;
    char str[22],s1[11],s2[11];
    while(gets(str)&&str[0] != '\0')
    {
        sscanf(str,"%s %s",s1,s2);
        mp[s2]=s1;
    }
    while(gets(str))
    {
        if(mp.find(str)!=mp.end())
        {
            cout<<mp[str]<<endl;
        }
        else cout<<"eh"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值