Power Strings
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 57771 | Accepted: 23994 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int maxn=1000005;
char s[maxn];
int Next[maxn];
int minx=INF;
void get_next(){
int j=0,k=-1;
int len=strlen(s);
Next[0]=-1;
while(j<len){
if(k==-1||s[j]==s[k]){
j++;
k++;
if(s[j]==s[k]){
Next[j]=Next[k];
}else
Next[j]=k;
}else
k=Next[k];
}
}
int main(){
int ans;
while(~scanf("%s",s)&&strcmp(s,".")){
ans=1;
minx=INF;
get_next();
int len=strlen(s);
if(len%(len-Next[len])==0)
ans=len/(len-Next[len]);
printf("%d\n",ans);
}
return 0;
}