【POJ】2406Power Strings(KMPnext数组求解循环节问题)

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 62365 Accepted: 25776

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

题目大意:现在给你一个字符串,问你这个字符串是是由最小循环节循环几次的到的

思路:可能上面的题意说的不大好,但是这个题目的意思还是挺好理解的

下面说一下思路:

next数组,我们知道里面保存的是他的前面字符串的最大前缀后缀相等的位数,

然后我们知道,什么时候len/(len-next[len])是大于1的,是那个next数组的数值大于len的一半的时候,

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
const int maxn=1000005;
int next[maxn];
char str[maxn];
void getnext(char p[])
{
    next[0]=-1;
    int j=0,k=-1;
    int len=strlen(p);
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            k++,j++;
            next[j]=k;
        }
        else
            k=next[k];
    }
}
int main()
{
    while(scanf("%s",str))
    {
        if(str[0]=='.') break;
        int len=strlen(str);
        getnext(str);
        if(len%(len-next[len])==0)
        {
            cout<<len/(len-next[len])<<endl;
        }
        else
            cout<<1<<endl;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值