CCPC网络赛--hdu 6438--买卖--贪心

http://acm.hdu.edu.cn/showproblem.php?pid=6438

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 759    Accepted Submission(s): 199


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i -th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i -th city and choose exactly one of the following three options on the i -th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250 ), indicating the number of test cases. For each test case:
The first line has an integer n . (1≤n≤105 )
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i -th city. (1≤ai≤109 )
It is guaranteed that the sum of all n is no more than 5×105 .

 

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

 

Sample Output

 
16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

 

题意:你有无数的钱,每次只能买卖一件物品,在获得最大利润的同时,要使得交易次数最少。输出最大利润和交易次数。

分析:贪心,贪心大法好,自己贪心能力比较弱了

/*#include<bits/stdc++.h>
using namespace std;
typedef long long ll;*/
#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int n,m;
ll ans,tmp,x,num;
///https://blog.csdn.net/qq_37891604/article/details/81321394
///不懂优先队列的可以看上面这篇博客
priority_queue<ll,vector<ll>,greater<ll> >q,p;///队头元素最小,即队列里的元素有小到大排,例如1 2 3
///为什么由小到大,因为肯要尽量买便宜的吗
///p:已经卖了的钱(以这个钱卖的)
///q:将要卖的钱(将要以这个价格卖出)(买进来放到队列里,将要把它卖掉)
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        ans=num=0;
        while(!p.empty())p.pop();
        while(!q.empty())q.pop();
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&x);
            if(!p.empty())///已经卖
            {
                tmp=p.top();///已经卖的
                if(tmp<x&&!q.empty()&&q.top()<tmp)
                {///q.top()<tmp将要卖的小于已经卖的,tmp<x已经卖得小于当前的价格,
                    ///q.top<tmp是因为tmp<q.pop<x的时候就要卖tmp
                    num++;
                    ans+=x;///将要卖的以x价格卖出
                    q.pop();
                    p.push(x);
                }
                else if(tmp<x)
                {///tmp<x已经卖得小于当前的价格,也就是卖便宜了,那我反悔,我要在现在把它卖了
                    p.pop();
                    q.push(tmp);
                    ans-=2*tmp;///以前卖它赚了tmp,需要减去,然后再买回它来,比如tmp=5,x=10,以前以5元卖出赚了5,首先把我赚的五元减去,在花5元买它
                    ans+=x;
                    p.push(x);
                }
                else if(!q.empty()&&q.top()<x)///将要卖的价格小于现在的价格
                {
                    num++;
                    p.push(x);
                    ans+=x;
                    q.pop();
                }
                else
                {
                    ans-=x;///先假买了,放到将要卖的队列里
                    q.push(x);
                }
            }
            else if(!q.empty()&&q.top()<x)///将要卖
            {
                num++;
                p.push(x);
                ans+=x;
                q.pop();
            }
            else
            {
                ans-=x;///先假买了,放到将要卖的队列里
                q.push(x);
            }
        }
        while(!q.empty())///把假买的多减掉的钱加回来
        {
            ans+=q.top();
            q.pop();
        }
        printf("%lld %lld\n",ans,num*2);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值