POJ 2796 Feel Good

                                                                                                                                                Feel Good
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 14816 Accepted: 4103
Case Time Limit: 1000MS Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

题目大意:给你几个数字,你要找出他的一个连续子序列,这段连续子序列的和乘以这段连续子序列中的最小值为最大(与其他的连续子序列相比)


可以以自己为最小值向左向右扩展到不能扩展为止。记录下他能到达的最大的左右端点和乘积,最后比较。

要用long long ,不然会炸

#include<iostream>
#include<cstdio>
using namespace std;
typedef long long ll;
ll a[100010],sum[100010],l[100010],r[100010];
int main(){
  int n;
  scanf("%d",&n);
  for(int i=1;i<=n;i++){
    scanf("%lld",&a[i]);
    sum[i]=a[i]+sum[i-1];
    l[i]=r[i]=i;
  }
  for(int i=2;i<=n;i++){
    while(l[i]>1&&a[l[i]-1]>=a[i])
      l[i]=l[l[i]-1];
  }
  for(int i=n-1;i>=0;i--){
    while(r[i]<n&&a[r[i]+1]>=a[i])
      r[i]=r[r[i]+1];
  }
  ll ans=-1;
  int left,right;
  for(int i=1;i<=n;i++){
    ll temp=a[i]*(sum[r[i]]-sum[l[i]-1]);
    if(temp>ans){
      ans=temp;
      left=l[i];
      right=r[i];
    }
  }
  printf("%lld\n%d %d",ans,left,right);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值