HDU 1698 Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36260    Accepted Submission(s): 17682


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend

线段树的模板题

主要是要用到lazy标记,但是我不会,于是照着网上的题解打了个-1标记

#include<iostream>
using namespace std;
const int maxn=100010;
struct Node{
	int l,r,val;
}tree[maxn*4];
void build(int root,int left,int right){
	tree[root].l=left;
	tree[root].r=right;
	tree[root].val=1;
	if(left==right) return;
	int mid=(left+right)/2;
	build(root*2,left,mid);
	build(root*2+1,mid+1,right);
	return;
}
void updata(int root,int left,int right,int num){
	if(tree[root].val==num) return;
	if(tree[root].l==left&&tree[root].r==right){
		tree[root].val=num;
		return;
	}
	if(tree[root].val!=-1){
		tree[root*2].val=tree[root*2+1].val=tree[root].val;
		tree[root].val=-1;
	}
	int mid=(tree[root].l+tree[root].r)/2;
	if(left>mid) updata(root*2+1,left,right,num);
	else if(right<=mid) updata(root*2,left,right,num);
	else{
		updata(root*2,left,mid,num);
		updata(root*2+1,mid+1,right,num);
	}
}
int question(int root){
	if(tree[root].val!=-1)
		return (tree[root].r-tree[root].l+1)*tree[root].val;
	else
		return question(root*2)+question(root*2+1);
}
int main(){
	int test;
	scanf("%d",&test);
	for(int t=1;t<=test;t++){
		int n,que;
		scanf("%d%d",&n,&que);
		build(1,1,n);
		while(que--){
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			updata(1,x,y,z);
		}
		printf("Case %d: The total value of the hook is %d.\n",t,question(1));
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值