HDU 5631 Rikka with Graph

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1247    Accepted Submission(s): 649


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number  T(T30) ——The number of the testcases.

For each testcase, the first line contains a number  n(n100) .

Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

Source
 
题目大意:有n个点,n+1条边,执行删边操作使得这个图仍然连通,问有多少种删边操作

n个点连通肯定是有n-1条边,所以只要删一条边或者是两条边,再用并查集判断是否连通即可

#include<iostream>
using namespace std;
const int maxn=110;
int tree[maxn];
int numa[maxn];
int numb[maxn];
void init(){
	for(int i=0;i<maxn;i++) tree[i]=i;
}
int find(int x){
	return x==tree[x]?x:tree[x]=find(tree[x]);
}
void merge(int a,int b){
	int x=find(a);
	int y=find(b);
	if(x!=y) tree[x]=y;
}
int main(){
	int test;
	cin>>test;
	while(test--){
		int n;
		cin>>n;
		for(int i=0;i<=n;i++){
			cin>>numa[i]>>numb[i];
		}
		int ans=0;
		for(int i=0;i<=n;i++){
			init();
			for(int j=0;j<=n;j++){
				if(i==j) continue;
				merge(numa[j],numb[j]);
			}
			int res=0;
			for(int i=1;i<=n;i++){
				if(tree[i]==i) res++;
			}
			if(res==1) ans++;
		}
		for(int i=0;i<=n;i++){
			for(int j=i+1;j<=n;j++){
				init();
				for(int k=0;k<=n;k++){
					if(k==i||k==j) continue;
					merge(numa[k],numb[k]);
				}
				int res=0;
				for(int k=1;k<=n;k++){
					if(tree[k]==k) res++;
				}
				if(res==1) ans++;
			}
		}
		cout<<ans<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值