HDU 5627 Clarke and MST

 

Clarke and MST

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 552    Accepted Submission(s): 316

 

 

Problem Description

Clarke is a patient with multiple personality disorder. One day he turned into a learner of graph theory. 
He learned some algorithms of minimum spanning tree. Then he had a good idea, he wanted to find the maximum spanning tree with bit operation AND. 
A spanning tree is composed by n−1 edges. Each two points of n points can reach each other. The size of a spanning tree is generated by bit operation AND with values of n−1 edges. 
Now he wants to figure out the maximum spanning tree.

 

 

Input

The first line contains an integer T(1≤T≤5), the number of test cases. 
For each test case, the first line contains two integers n,m(2≤n≤300000,1≤m≤300000), denoting the number of points and the number of edge respectively.
Then m lines followed, each line contains three integers x,y,w(1≤x,y≤n,0≤w≤109), denoting an edge between x,y with value w. 
The number of test case with n,m>100000 will not exceed 1. 

 

 

Output

For each test case, print a line contained an integer represented the answer. If there is no any spanning tree, print 0.

 

 

Sample Input

 

1 4 5 1 2 5 1 3 3 1 4 2 2 3 1 3 4 7

 

 

Sample Output

 

1

 

 

Source

BestCoder Round #72 (div.2)

 

题目大意,求一个生成树,他的每条边权值进行与运算要求最大

 

一开始用prim算法写的时候数组太大了...于是用了不经常用的kruskal算法....突然发现超级好用啊....

我直接按了最大生成树的写法来写再对每个边的权值进行与运算

 

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=3e5+7;
struct Node{
	int u,v,val;
}map[maxn];
int tree[maxn];
int n,m,sum;
bool flag;
void init(){
	for(int i=1;i<=maxn;i++){
		tree[i]=i;
	}
}
bool cmp(Node a,Node b){
	return a.val>b.val;
}
int find(int x){
	return x==tree[x]?x:tree[x]=find(tree[x]);
}
void merge(int a,int b){
	int x=find(a);
	int y=find(b);
	if(x!=y) tree[x]=y;
}
void kruskal(){
	for(int i=0;i<m;i++){
		int a=find(map[i].u);
		int b=find(map[i].v);
		if(a!=b){
			merge(map[i].u,map[i].v);
			if(!flag){
				sum=map[i].val;
				flag=true;
			}
			sum=sum&map[i].val;
		}
	}
}
int main(){
	int test;
	cin>>test;
	while(test--){
		flag=false;
		sum=0;
		cin>>n>>m;
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&map[i].u,&map[i].v,&map[i].val);
			//cin>>map[i].u>>map[i].v>>map[i].val;
		}
		sort(map,map+m,cmp);
		init();
		kruskal();
		cout<<sum<<endl;
	}
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值