HDU 3032 Nim or not Nim?(SG函数打表找规律)

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2802    Accepted Submission(s): 1450


 

Problem Description

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

 

 

Input

Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

 

 

Output

For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.

 

 

Sample Input

2
3
2 2 3
2
3 3

Sample Output

lice
Bob

题目大意:有几堆石头,每个人可以拿一堆里任意数量的石头(不能不拿),也可以将石头分为两堆,问最后谁赢

重新把博弈论看了一遍,感觉终于懂了SG函数.....

考虑SG函数打表,可以得到SG[0]=0,SG[1]=1,对于有两个石头的,它的后继状态就是只剩0个石头,只剩1个石头,分为了(1,1)三种情况,对着这三种情况求SG值就可以得到SG[2],对于有3个石头的,它的后继状态就是剩0,1,2个石头,或者是分为(1,2),对这四种情况求SG值就可得到SG[3]。以此类推.......得出SG函数每个状态的值后就可以打表找规律了

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e6+7;
int num[maxn];
bool vis[maxn];
int sg[100];
void init()
{
    sg[0]=0;
    sg[1]=1;
    for(int i=2;i<=99;i++)
    {
        memset(vis,false,sizeof(vis));
        for(int j=1;j<=i;j++)
        {
            vis[sg[i-j]]=true;剩多少个石头
        }
        for(int j=1;j<i;j++)
        {
            vis[sg[j]^sg[i-j]]=true;///分成的两堆各有多少石头
        }
        for(int j=0;;j++)
        {
            if(!vis[j])
            {
                sg[i]=j;
                break;
            }
        }
    }
    return;
}
int main()
{
    //init();
    int test;
    scanf("%d",&test);
    while(test--)
    {
        int n;
        scanf("%d",&n);
        //for(int i=1;i<=100;i++)
        //{
        //    printf("%d %d\n",i,sg[i]);
        //    if(i%5==0) puts("");
        //}
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int x;
            scanf("%d",&x);
            if(x%4==3) ans^=(x+1);
            else if(x%4==0) ans^=(x-1);
            else ans^=x;
        }
        if(ans!=0) puts("Alice");
        else puts("Bob");
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值