zoj-3829 Known Notation(贪心)

3 篇文章 0 订阅
Known Notation

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input
3
1*1
11*234**
*
Sample Output
1
0
2

题目意思就是说给你一个只有数字和 '*'组成的字符串,其中'*'代表运算符号。问你能不能通过插入字符或者交换任意两个字符使得该字符串变为后缀表达式,可以多个挨着的数字当做一个数。求最少的操作次数。

贪心的来做,要变成后缀表达式,那么操作完之后字符串的最后一定是运算符号而不会是数字,所以一开始就想到,如果当前运算符号的前面的数字不够2个的话,就把这个运算符号和从后面开始找的第一个数字交换位置。而且如果最后剩下了很多个数字,只要最后一个是运算符号,那么前面的数字随意组合,只要能分成两个数就行。

这样的话运算符号是不需要插入的,只要 运算符数<数字数 表达式一定可以转化为后缀表达式。

然后插入数字的话 只要数字数比运算符数大1就行了,按照运算符要放到后面的想法,数字都放到前面就好。

看1**1这个例子的话可以发现 先插入数字再遍历,得到的操作次数更少,所以如果数字不够先插入数字,再遍历。

下面是代码

#include <bits/stdc++.h>
#include <cstring>
#define INF 0x3f3f3f3f
#define MOD 1e9+7
using namespace std;

int main()
{
    int T;
    cin>>T;
    string s;
    while(T--)
    {
        cin>>s;
        int num=0,op=0,ans=0;
        for(int i=0;i<s.size();i++)
        {
            if(s[i]=='*')
                op++;
            else
                num++;
        }
        if(op>=num)
        {
            ans+=op+1-num;
            num=op+1-num;
        }
        else
            num=0;
        for(int i=0;i<s.size();i++)
        {
            if(s[i]=='*')
            {
                if(num>1)
                    num--;
                else
                {
                    for(int j=s.size()-1;j>i;j--)
                    {
                        if(s[j]!='*')
                        {
                            swap(s[i],s[j]);
                            ans++;
                            break;
                        }
                    }
                }
            }
            if(s[i]!='*')
                num++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值