UVa 540 STL之queue的运用

Queues and Priority Queues are data structures which are known to most computer scientists. The
Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the
queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches
the queue from head to tail to check if some of its teammates (elements of the same team) are already
in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail
and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are
processed from head to tail in the order they appear in the team queue.
Your task is to write a program that simulates such a team queue.

Input

The input file will contain one or more test cases. Each test case begins with the number of teams
t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements
belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A
team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:
• ENQUEUE x — enter element x into the team queue
• DEQUEUE — process the first element and remove it from the queue
• STOP — end of test case
The input will be terminated by a value of 0 for t.
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation
of the team queue should be efficient: both enqueing and dequeuing of an element should
only take constant time.

Output

For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then,
for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line
after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203
Scenario #2
259001
259002
259003
259004
259005

260001


题目大意: 

给出若干个集合,集合包含若干个数,然后给出一条队列,每次可以往队列中加入数或者删除数。加入数的如果所在的集合在队列中存在的话。就直接加入到同一集合并且已经在队列中的数的后面。否则就加入到队列的最后面。删除数每次删除队列的第一个。并且输出出来。

解题思路:

集合本身采用map来保存,键值储存数本身。映射值储存所在的集合编号。大队列储存的元素是小队列所对应的集合编号。小队列储存的是目前排在队伍中的该集合的所有数,并且按先后顺序排列。

码:

#include <iostream>
#include <list>
#include <queue>
#include <map>
#include <cstdio>
#include <string>

using namespace std;

typedef map<int,int> Map;

typedef queue<int> Queue;

int main()
{
    //freopen("in.txt","r",stdin);
    int T,n,m,o=0;
    string s;
    while(scanf("%d",&T)!=EOF)
    {
        o++;
        if(T==0)
            break;
        Map ma;
        for(int i=0 ; i<T; i++)
        {
            scanf("%d",&n);
            for(int j=0; j<n; j++)
            {
                int k ;
                scanf("%d",&k);
                ma[k]=i;
            }
        }
        printf("Scenario #%d\n",o);
        Queue qu,qui[1000];
        while(cin>>s)
        {
            if(s[0]=='S')
                break;
            if(s[0]=='E')
            {
                scanf("%d",&m);
                int t=ma[m];
                if(qui[t].empty()){
                    qu.push(t);
                    qui[t].push(m);
                }
                else
                    qui[t].push(m);
            }
            else
            {
                int n=qu.front();
                printf("%d\n",qui[n].front());
                qui[n].pop();
                if(qui[n].empty())
                    qu.pop();
            }
        }
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值