报"ImportError: DLL load failed: 找不到指定的模块"的解决办法(2)

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_37960402/article/details/89022877

前不久我用python输入 import scipy.io as scio,报错:无法启动报"ImportError: DLL load failed: 找不到指定的模块"的解决办法,这个问题解决了,没想到又出现了同一个类似的错误。
########################################################

如果我直接pip install tensorflow的话,是不会报错的。

如果用pip install tensorflow-gpu,当我import keras 或者 import tensorflow的时候就会报错。这就说明我的问题是出现在安装tensorflow-gpu。

报错:ImportError: DLL load failed: 找不到指定的模块。Failed to load the native TensorFlow runtime.

在这里插入图片描述
我的最初版本是win10 +cuda9.2+cudnn7.5+python3.7。
我尝试了一下工作:
1、将python版本换位3.6---------失败(这时候我的tensorflow-gpu版本只有1.13的,不可以降低版本)
2、将cudnn7.5改为cudnn7.2-----失败(这时候tensorflow-gpu版本可以改变,尝试了各种版本从1.8-1.13,都失败了)
3、重装了vs2015—失败,还装了vs2017—失败

最终尝试:之前由于网络问题,cuda一直下载不了,今天不知道为什么又可以下载了,重新下载了一个cuda9.0+cudnn7.3。
刚开始tensorflow-gpu版本是13.0,还是一样报错,因为tensorflow版本太高了,降低一下版本。
pip install --upgrade tensorflow-gpu==1.12.0

本以后还会报错,没想到居然成功了。这个问题大多数就是tensorflow的版本和你的cudnn不兼容。
最终的版本==win10 +cuda9.0+cudnn7.2+python3.6+tensorflow1.12

cudnn和tensorflow的版本
在这里插入图片描述

cuda下载地址:https://developer.nvidia.com/cuda-toolkit-archive
cudnn下载:https://developer.nvidia.com/rdp/cudnn-archive

展开阅读全文

没有更多推荐了,返回首页