Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:\ N1 N2 tag radix\ Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
/**
1.将0~z映射成0~35
2.将N1转换成十进制
3.确定N2的最低进制
4.用二分搜索确定N2的进制,每次比较N2转换成十进制后与N1的关系,大于则搜索右边,小于搜索左边
**/
typedef long long LL;
const LL INF = (1LL << 63) - 1;
LL Map[256];
void init(){
for(char c = '0'; c <= '9';c++){
Map[c] = c - '0';
}
for(char c = 'a';c <= 'z';c++){
Map[c] = c - 'a' + 10;
}
}
LL convert(char a[], LL radix,LL bound){
int len = strlen(a);
LL ans = 0;
for(int i = 0;i < len;i++){
ans = ans * radix + Map[a[i]];
if(ans > bound || ans < 0) return -1; //判断溢出,证明比N1要大
}
return ans;
}
int cmp(char N2[],LL radix,LL bound){
LL num = convert(N2,radix,bound);//将N2转换为10进制
if(num < 0) return 1;//溢出,则N2比N1大
if(num < bound) return -1; //N2<N1
else if(num == bound) return 0;//N2==N1
else return 1;//N2>N1
}
LL binarySearch(char N2[],LL low,LL high,LL bound){
LL mid;
while(low <= high){
mid = (low + high) / 2;
int flag = cmp(N2,mid,bound);
if(flag == 1) high = mid - 1;//N2 > N1,搜索左区间
else if(flag == -1) low = mid + 1;//N2 < N1 搜索右区间
else return mid;//返回N2的进制
}
return -1;//表示未找到对应的进制
}
LL findMaxDigit(char N2[]){
LL max = -1;
int len = strlen(N2);
for(int i = 0;i < len;i++){
if(max < Map[N2[i]]){
max = Map[N2[i]];
}
}
return max + 1;//返回的是N2的最小进制的下界
}
int main(){
char N1[20],N2[20],temp[20];
LL tag,radix;
scanf("%s %s %lld %lld",&N1,&N2,&tag,&radix);
if(tag == 2){
strcpy(temp,N1);
strcpy(N1,N2);
strcpy(N2,temp);
}
init();
LL low = findMaxDigit(N2);
LL bound = convert(N1,radix,INF);
LL high = max(low,bound) + 1;
LL ans = binarySearch(N2,low,high,bound);
if(ans == -1) printf("Impossible\n");
else printf("%lld\n",ans);
system("pause");
return 0;
}