PAT A1081 分数运算规则,最大公约公倍数

 

1081 Rational Sum (20)(20 分)

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

题目大意:给出一些分数,让我们计算他们的和,并且注意最后的输出格式

 思路:分数可以用结构体存储,要注意分数的化简规则:

1.当分母为负数时候,让分子为负数(统一格式,虽然这题已经保证只有分子为负数)

2.当分子为0时候,让分母为1

3.计算出分子分母最大公约数(欧几里得),并让他们除以最大公约数

此时化简出来的分数为假分数,相加时候用假分数更方便,最后输出时候注意判断几个特殊情况即可

#include <cstdio>
#include <string>

using namespace std;
typedef long long LL;
const int maxN = 110;
//定义分数的结构体
struct FS{
	LL up,down;
}fs[maxN];

//计算两个数的最大公约数,求最小公倍数ab/d,d为最大公约数,为了保证不越界,可以a/d*b来求
LL gcd(LL a, LL b){
	if(b==0) return a;//此处注意0与a的最大公约数是a而不是0
	else return gcd(b,a % b);
}
//分数化简,1.若分母为负数,则让分子为负数(这题已经保证只有分子才会为负)
//2.若分子为0,则让分母为1
//3.求出分子分母的最大公约数,并约去.注意应该是分子分母的绝对值
void reduction(FS &a){
	if(a.up == 0) a.down = 1;
	else{
		LL d = gcd(abs(a.up),a.down);
		a.up = a.up / d;
		a.down = a.down / d;
	}
}

int main(){
	int n;
	scanf("%d",&n);
	FS ans;
	ans.up = 0;
	ans.down = 1;
	for(int i = 0;i < n;i++){
		LL up,down;
		scanf("%lld/%lld",&up,&down);
		ans.up = ans.up * down + ans.down * up;
		ans.down = ans.down * down;
		reduction(ans);
		//printf("%lld/%lld ",ans.up,ans.down);
	}
	if(ans.down == 1){//为0或者其余整数
		printf("%lld\n",ans.up / ans.down);
	}else if(ans.up > ans.down){//假分数
		LL a = ans.up/ans.down;//整数部分
		printf("%lld %lld/%lld\n",a,ans.up - (a*ans.down),ans.down);
	}else{//真分数
		printf("%lld/%lld",ans.up,ans.down);
	}
	system("pause");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值