05-树9 Huffman Codes(30 分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No
#include<iostream>
#include<fstream>
#include<vector>
#include<algorithm>
#include<string>
#include<map>
#include<queue>
#include<functional>
using namespace std;
//ifstream inFile("C:\\Users\\DELL\\Desktop\\in.txt", ios::in);
typedef struct HTNode* HuffmanTree;
struct HTNode{
	char C;
	int Weight;
	HuffmanTree Left;
	HuffmanTree Right;
	
};
struct Node{
	char C;
	int Count;
};
struct Rule
{
	bool operator ()(const HuffmanTree H1, const HuffmanTree  H2)
	{
		return H2->Weight < H1->Weight;
	}
};
HuffmanTree Huffman(priority_queue<HuffmanTree, vector<HuffmanTree>, Rule> H,int N)
{
	HuffmanTree T;
	for(int i=1;i<N;++i){
		T = new HTNode;
		T->Left = H.top();
		H.pop();
		T->Right = H.top();
		H.pop();
		T->Weight = T->Right->Weight + T->Left->Weight;
		H.push(T);
	}
	return H.top();
}
int WPL(HuffmanTree H,int Depth)
{
	if(!H->Left&&!H->Right  ){
		return Depth*(H->Weight);
	}else{
		return WPL(H->Left, Depth + 1) + WPL(H->Right, Depth + 1);
	}
}
void Print(map<char,string> m)
{
	for(auto it=m.cbegin();it!=m.cend();++it){
		cout << it->first << " " << it->second << endl;
	}
}
bool InsertTree(HuffmanTree& Head, map<char, string>::const_iterator it)
{
	string str = it->second;
	char ch = it->first;
	HuffmanTree it1 = Head;
	for(size_t i=0;i<str.size();++i){
		if(str[i]=='0'){
			if(it1->Left ==nullptr){
				HuffmanTree tem = new HTNode;
				tem->Left = tem->Right = nullptr;
				tem->C = '-';
				it1->Left = tem;
				it1 = tem;
			}else{
				it1 = it1->Left;
				if(it1->C !='-'){
					return false;
				}
			}
		}else if(str[i]=='1'){
			if(it1->Right ==nullptr){
				HuffmanTree tem = new HTNode;
				tem->Left = tem->Right = nullptr;
				tem->C = '-';
				it1->Right = tem;
				it1 = tem;
			}else{
				it1 = it1->Right;
				if (it1->C != '-') {
					return false;
				}
			}
		}
	}
	if(it1->Left !=nullptr||it1->Right !=nullptr){
		return false;
	}else{
		if(it1->C !='-'){
			return false;
		}else{
			it1->C = ch;
			return true;
		}
	}
}
void  Judge(int MinCode,Node* node,int N)
{
	map<char, string> m;
	for (int i = 0; i < N;++i) {
		char c;
		string Count;
		cin >> c >> Count;
		m.insert(make_pair(c, Count));
	}
	//Print(m);
	int sumWeight = 0;
	for(int i=0;i<N;++i){
		sumWeight += node[i].Count *m[node[i].C].size();
	}
	//cout <<"sumWeight="<< sumWeight << endl;
	if(sumWeight!=MinCode){
		cout << "No" << endl;
	}else{
		int ret = 1;
		HuffmanTree Head = new HTNode;
		Head->Left = Head->Right = nullptr;
		Head->C ='-';
		for(auto it=m.cbegin();it!=m.end();++it){
			if(!InsertTree(Head, it)){
				ret = 0;
				break;
			}
		}
		if(ret==1){
			cout << "Yes" << endl;
		}else{
			cout << "No" << endl;
		}
	}
}


int main()
{
	
	priority_queue<HuffmanTree,vector<HuffmanTree>,Rule> H;
	int N,M;
	
	cin >> N;
	Node* node = new Node[N];
	for(int i=0;i<N;++i){
		HuffmanTree h=new HTNode;
		cin >> h->C >> h->Weight;
		node[i].C = h->C;
		node[i].Count = h->Weight;
		h->Right = nullptr;
		h->Left = nullptr;
		H.push(h);
	}
	cin >> M;
	HuffmanTree Head = Huffman(H,N);
	int Count = WPL(Head, 0);
	//cout << Count << endl;
	while(M--){
		Judge(Count, node, N);
	}

	
	//inFile.close();
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值