hdoj 1004 Let the Balloon Rise(map)

Let the Balloon Rise(链接)



Sample Input
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
red pink
 
输出出现次数最多的颜色  用map存一下就好了
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;

int main()
{
    map<string,int> B;
    string Color,Max;
    int n;
    while(~scanf("%d",&n)&&n!=0)
    {
        B.clear();
        while(n--)
        {
            cin>>Color;
            B[Color]++;
        }
        int max=0;
        map<string,int>::iterator it;   //迭代器
        for(it=B.begin();it!=B.end();it++)
        {
            if(it->second>max)
            {
                max=it->second;    //只能用  ->  不可以用dian点.
                Max=it->first;
            }
        }
        cout<<Max<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值