HDOJ2028_Lowest Common Multiple Plus

Problem Description
求n个数的最小公倍数。
 
Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 
Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 
Sample Input
  
  
2 4 6 3 2 5 7
 
Sample Output
  
  
12 70


import java.util.Scanner;

/**
 * 求n个数的最小公倍数。
 * @author 逸川同学
 * 
 */
public class P2028 {
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while(scanner.hasNext()){
			int  n = scanner.nextInt();
			int[]a = new int[n];
			a[0] = scanner.nextInt();
			int max = a[0];
			for (int i = 1; i < a.length; i++) {
				a[i]= scanner.nextInt();
				if(max<a[i]){
					max = a[i];
				}
			}
			int q = max;
			while(true){
				int flag = 0;
				for (int i = 0; i < a.length; i++) {
					if(q%a[i] != 0){
						q += max; 
						flag = 1;
						break;
					}
				}
				if(flag == 0){
					System.out.println(q);
					break;
				}
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值