HDOJ1335 Basically Speaking(进制转换)

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3642    Accepted Submission(s): 1487


Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.
 

Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
 

Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.
 

Sample Input
  
  
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
 

Sample Output
  
  
120 78 1765 7CA ERROR 11001 12D687 D071
  题意:将将n进制的num 转换为 m进制。
要是转换时候大于七位数,输出  ERROR。否则按题目要求的格式输出。
import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while(scanner.hasNext()){
			//将n进制的num 转换为 m进制
			String num = scanner.next();
			int n = scanner.nextInt();
			int m = scanner.nextInt();
//			if(num.equals("0")){//不需要
//				System.out.printf("%7d",0);
//				System.out.println();
//			}
			//先转换为十进制
			int res = Integer.parseInt(num, n);
//			System.out.println(res);
			//再转换为m进制
			String string = change(res, m);
			//输出
			if(string.length()>7){
				System.out.println("  ERROR");
			}else {
				System.out.printf("%7s",string);
				System.out.println();
			}
		}
	}
	public static String change(int n,int m){
//		十进制n的m进制
		char ch[] = {'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F'};
		String string = "";
		while(n/m>0){
			string = ch[n%m]+string;
			n/=m;
		}
		if(n>0){//如果还有余数
			string = ch[n]+string;
		}
		return string;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值