HDOJ1393 Number Steps(找规律)

Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5919    Accepted Submission(s): 3583


Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.
 

Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
 

Output
For each point in the input, write the number written at that point or write No Number if there is none.
 

Sample Input
  
  
3 4 2 6 6 3 4
 

Sample Output
  
  
6 12 No Number
  这种题目最好自己多做测试。
认真观察题目给出的坐标图,x=y这条线上的规律最好发现。

情况1:首先当然是x=y的了,其次就是当x=y是偶数的时候,结果n正好是x+y。
情况2:而当x=y是奇数的时候,结果n正好是他的x-1,y-1对应点的n值加一。

情况3:然后是x=y下面那条线对应的数n。
都是他上面一个数的值减二。
import java.util.Scanner;

public class Main{
	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		int cases = scanner.nextInt();
		while (cases-- > 0) {
			int x = scanner.nextInt();
			int y = scanner.nextInt();
			if(x==y && x%2==0){//情况1
				System.out.println(2*x);
				continue;
			}
			if(x==y && x%2!=0){//情况2
				System.out.println((x-1)*2+1);
				continue;
			}
			if(y+2==x){//情况3(再细分)
				if(x%2==0){
					System.out.println(2*x-2);
					continue;
				}
				if(x%2!=0){
					System.out.println((x-1)*2-1);
					continue;
				}
			}
			
			System.out.println("No Number");
		}
	}
}
/*
测试数据
6
0 0
1 1
4 4
3 3
5 3
4 2

0 1 8 5 7 6
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值