hdu1391(水题)

Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7397    Accepted Submission(s): 4499


 
Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.
 



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.
 
 
Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
 
 
Output
For each point in the input, write the number written at that point or write No Number if there is none.
 
 
Sample Input
 
3 4 2 6 6 3 4
 
 
Sample Output
 
6 12 No Number

     很容易发现数字排列规律,从坐标(0,0)开始,

     分别以两条线S型排布

     数据范围从0-->5000,如果坐标满足x==y||x==y+2则存在值,不然输出No Number

     不必打表(直接计算效率较高,测试数据比较水),直接根据坐标计算值就可以了。上AC代码

//hdu1391
//by QQ
//date:2021.03.28
#include<iostream>
using namespace std;
//judgment :判断
void judgment(int x,int y)
{
	if(x==y)
	{
		if(x%2)
		{
			cout<<2*x-1<<endl;
		}
		else
		{
			cout<<2*x<<endl;
		}
	}
	else if(x==y+2)
	{
		if(y%2==0)
			cout<<2*(y+1)<<endl;
		else
			cout<<2*y+1<<endl;
	}
	else
		cout<<"No"<<" "<<"Number"<<endl;
}
int main()
{
	int t,x,y;
	cin>>t;
	while(t--)
	{
		cin>>x>>y;
		judgment(x,y);
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值