HDOJ1718 Rank

Rank

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5857    Accepted Submission(s): 2337


Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.
 

Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
 

Output
For each test case, output a line giving Jackson’s rank in the class.
 

Sample Input
  
  
20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0
 

Sample Output
  
  
2
  如题,就是一个排序题,但不是需要排序,输入的时候判断出需要求的学生的成绩,然后一个for,比较分数大小。
分数大的,排名就++
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while(scanner.hasNext()){
			int num = scanner.nextInt();
			List<Integer>listMark  = new ArrayList<Integer>();
			int score = 0;
			while(true){
				int n = scanner.nextInt();
				int m = scanner.nextInt();
				if(n==0 && m==0){
					break;
				}
				if(n==num){
					score = m;
				}
				listMark.add(m);
			}
			int rank = 1;
			for (int i = 0; i < listMark.size(); i++) {
				if(listMark.get(i)>score){
					rank++;
				}
			}
			System.out.println(rank);
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值