1031 甲级 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

这题实际上不难,就是刚开始要求没看明白,首先要尽量使宽与高接近,也就是说要尽量往正方形上靠,其次,对于n1,n2,n3都是有要求的,n1=n3<=n2,并且3<=n2<=N,而n1,n2,n3的定义分别是:n1,n3是这个U形的高,n2为这个U形的宽,因此在初步计算n1的时候需要用到n1=(N+2)/3,因为三条边一共有两个重合点,这两个重合点需要计算进去,然后要对当前的n1,n2,n3进行判断,看是否符合题目条件,不符合则进行调整,这一部分我使用了一个while循环,很简单就不赘述了,下面还是照例放上我的代码。

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string str;
	cin >> str;
	int N = str.length();
	int n1, n2, n3;
	n1 = n3 =(N+2)/3;
	n2 = N - n1 - n3;
	while (true)
	{
		if (n1+1 <= n2 && n2 >= 3 && n2 <= N)
		{
			break;
		}
		else
		{
			n1--;
			n3--;
			n2 += 2;
		}
	}
	for (int i = 0; i < n1; i++)
	{
		cout << str[i];
		for (int j = 0; j < n2-2; j++)
		{
			cout << " ";
		}
		cout << str[N-i-1];
		cout << endl;
	}
	for (int i = 0; i < n2; i++)
	{
		cout << str[n1+i];
	}
	system("pause");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值