[PAT A1058]A+B in Hogwarts

[PAT A1058]A+B in Hogwarts

题目描述

1058 A+B in Hogwarts (20 分)If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

输入格式

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

输出格式

For each test case you should output the sum of A and B in one line, with the same format as the input.

输入样例

3.2.1 10.16.27

输出样例

14.1.28

解析

这道题目很简单,属于送分题,具体题目翻译过来就是给定两个货币数(霍格沃兹货币格式,具体格式进制格式可以看题,也可以参考我的博客,下面)
[PAT B1037]在霍格沃茨找零钱

这里要强调一点的就是,我使用的是在B1037中的另一种我没有写出来的方法,就是把货币全部换成零钱,相加后再换回去,这样虽然很简单暴力,但是有可能导致溢出,所以数据使用的是long long型,不信?哈哈那可以去试一试,我是有一组数据过不了的
#include<iostream>
using namespace std;
const int Galleon = 17 * 29;
const int Sickle = 29;
int main()
{
 long long a1, b1, c1, a2, b2, c2;
 scanf("%lld.%lld.%lld %lld.%lld.%lld", &a1, &b1, &c1, &a2, &b2, &c2);
 c1 += a1*Galleon + b1*Sickle;
 c2 += a2*Galleon + b2*Sickle;
 c1 += c2;
 a1 = c1 / Galleon;
 b1 = c1%Galleon / Sickle;
 c1 = c1%Sickle;
 cout << a1 << "." << b1 << "." << c1;
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值