1058. A+B in Hogwarts (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
当相加为零时要处理。简单的另一种方法见
http://blog.csdn.net/cstopcoder/article/details/21556803

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月17日 20:05答案正确201058C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118010/10
1答案正确13082/2
2答案正确13082/2
3答案正确13082/2
4答案正确12562/2
5答案正确11802/2
#include<iostream>
#include<string>
using namespace std;  
long int Getnum(string s1,long int *l)
{ 
 long int temp=0,e=1;
 while((*l)>=0&&s1[*l]!='.')
 {
       temp=temp+(s1[*l]-'0')*e;
    e*=10; 
    (*l)--;
 }
 (*l)--; 
 return temp;
}
string Getstr(long int nn)
{
 string ss;
 char cc;  
 if(nn!=0)
 {
   while(nn>0)
   { 
  cc=nn%10+'0';
        ss=cc+ss;
  nn=nn/10; 
   } 
 }
 else
 {
  cc='0';
  ss=cc;
 }
 return ss;
}
int main()
{
  string A,B,sa;
  long int len1,len2,temp,c;
  cin>>A>>B;
  len1=A.length()-1;
  len2=B.length()-1; 
  c=0;
  temp=Getnum(A,&len1)+Getnum(B,&len2); 
  c=temp/29;
  temp%=29;
  sa="."+Getstr(temp);

  temp=c+Getnum(A,&len1)+Getnum(B,&len2);
  c=temp/17; 
  temp%=17;   
  sa="."+Getstr(temp)+sa;
 
  temp=c+Getnum(A,&len1)+Getnum(B,&len2);  
  sa=Getstr(temp)+sa;
  cout<<sa<<endl;
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值