[PAT A1022]Digital Library

[PAT A1022]Digital Library

题目描述

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

输出格式

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

输入样例

3

1111111

The Testing Book

Yue Chen

test code debug sort keywords

ZUCS Print

2011

3333333

Another Testing Book

Yue Chen

test code sort keywords

ZUCS Print2

2012

2222222

The Testing Book

CYLL

keywords debug book

ZUCS Print2

2011

6

1: The Testing Book

2: Yue Chen

3: keywords

4: ZUCS Print

5: 2011

3: blablabla

输出样例

1: The Testing Book

1111111

2222222

2: Yue Chen

1111111

3333333

3: keywords

1111111

2222222

3333333

4: ZUCS Print

1111111

5: 2011

1111111

2222222

3: blablabla

Not Found

解析

  1. 这道题从阅读难度上说并不难,其实就是构建一个简单的数字图书馆,输入n本书,每本书有6个元素,分别是id,书名,作者,关键词,出版社,出版年份。然后给出m个查询,根据查询关键词,给出相应的书的id。
  2. 自己水平还是太差了,自己想了好久也没有想出来一个好的STL能够处理这种情况,后来借鉴了晴神的观念,发现我们要顺着题目去做,题目给的是关键词,要我们查询的是书的id,那么对于每一个关键词,都有一个id的集合与之对应,这让我们联想到了map,我们使用5个map,每个map代表一个元素,并且与一个集合对应,那么结构就应该是:map<string,set<int>>,决定了结构,那么接下来的问题也就迎刃而解了。
  3. #include<iostream>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    map<string, set<int>> title, author, keyword, publisher, year;
    void query(map<string, set<int>> &m, string &str) {
    	if (m.find(str) != m.end()) {
    		for (auto it = m[str].begin(); it != m[str].end(); it++) {
    			printf("%07d\n", *it);
    		}
    	}
    	else printf("Not Found\n");
    }
    int main()
    {
    	int n;
    	scanf("%d", &n);
    	getchar();
    	for (int i = 0; i < n; i++) {
    		string str;
    		getline(cin, str);
    		int id = stoi(str);
    		getline(cin, str);
    		title[str].insert(id);
    		getline(cin, str);
    		author[str].insert(id);
    		string key;
    		while (cin >> key) {
    			keyword[key].insert(id);
    			char c = getchar();
    			if (c == '\n')break;
    		}
    		getline(cin, str);
    		publisher[str].insert(id);
    		getline(cin, str);
    		year[str].insert(id);
    	}
    	int m, num;
    	scanf("%d", &m);
    	for (int i = 0; i < m; i++) {
    		scanf("%d: ", &num);
    		string temp;
    		getline(cin, temp);
    		cout << num << ": " << temp << "\n";
    		if (num == 1) query(title, temp);
    		else if (num == 2) query(author, temp);
    		else if (num == 3) query(keyword, temp);
    		else if (num == 4) query(publisher, temp);
    		else if (num == 5) query(year, temp);
    	}
    	return 0;
    }

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值