PAT-A1022 Digital Library 题目内容及题解

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  •     Line #1: the 7-digit ID number;
  •     Line #2: the book title -- a string of no more than 80 characters;
  •     Line #3: the author -- a string of no more than 80 characters;
  •     Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  •     Line #5: the publisher -- a string of no more than 80 characters;
  •     Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  •     1: a book title
  •     2: name of an author
  •     3: a key word
  •     4: name of a publisher
  •     5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意

题目模拟一个数字图书馆,题目提供ID、书名、作者、关键词、出版商和出版年份的信息。题目给出一个请求序列,按照格式要求输出查询结果。

解题思路

  1. 建立若干map,建立关键词到图书ID的映射;
  2. 用set保存,所有ID自然增序排列;
  3. 按题目要求输出结果,并返回0值。

代码

#include<iostream>
#include<cstdio>
#include<map>
#include<set>
#include<string>
using namespace std;
//五个map变量分别建立书名、作者、关键词、出版社及出版年份与id的映射关系
map<string,set<int> > mpTitle,mpAuthor,mpKey,mpPub,mpYear;

void query(map<string,set<int> >& mp,string& str){//在mp中查找str 
    set<int>::iterator it; 
    if(mp.find(str)==mp.end()){//找不到 
        printf("Not Found\n");
    }else{//找到str 
        for(it=mp[str].begin();it!=mp[str].end();it++){
            printf("%07d\n",*it);//输出str对应的所有id 
        }
    }
}

int main(){
    int i,n,m,id,type;
    char c;
    string title,author,key,pub,year,temp;
    scanf("%d",&n);//书的数目 
    for(i=0;i<n;i++){
        scanf("%d",&id);//id 
        c=getchar();//接收掉id后面的换行
        getline(cin,title);//读入书名title 
        mpTitle[title].insert(id);//把id加入title对应的集合中 
        getline(cin,author);//读入作者author 
        mpAuthor[author].insert(id);//把id加入author对应的集合中 
        while(cin>>key){//每次读入单个关键词key 
            mpKey[key].insert(id);//把id加入key对应的集合中 
            c=getchar();//接收关键词key之后的字符 
            if(c=='\n'){//如果是换行,说明关键词输入结束 
                break;
            }
        }
        getline(cin,pub);//输入出版社pub 
        mpPub[pub].insert(id);//把id加入pub对应的集合中 
        getline(cin,year);//输入年份year 
        mpYear[year].insert(id);//把id加入year对应的集合中 
    }
    scanf("%d",&m);//查询次数
    for(i=0;i<m;i++){
        scanf("%d: ",&type);//查询类型 
        getline(cin,temp);//欲查询的字符串 
        cout<<type<<": "<<temp<<endl;//输出类型和该字符串 
        if(type==1){
            query(mpTitle,temp);//查询书名对应的所有id
        }else if(type==2){
            query(mpAuthor,temp);//查询作者对应的所有id
        }else if(type==3){
            query(mpKey,temp);//查询关键词对应的所有id
        }else if(type==4){
            query(mpPub,temp);//查询出版社对应的所有id
        }else{
            query(mpYear,temp);//查询出版年份对应的所有id
        }
    }
    return 0; 
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值