[PAT A1086]Tree Traversals Again

[PAT A1086]Tree Traversals Again

题目描述

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

输出格式

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

输入样例

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

输出样例

3 4 2 6 5 1

解析

题目的大致是给出中序遍历的出栈入栈顺序,然后要求我们给出后序遍历的顺序。

1.题目中默认存储的数据是从1~N,由于N个结点都需要入栈一次出栈一次,所以共有2N次操作

2.首先要弄明白的就是,正常情况下,我们需要知道中序遍历和先序遍历两个遍历顺序才能推导出后序遍历,但是这道题目不仅给出了中序遍历的顺序,还给出了出栈和入栈操作,这就需要我们模拟操作过程。我的想法是首先push会检查当前节点有没有左节点,没有就会给当前节点添加一个左节点,并令它的左节点为当前节点,同理右节点;Pop操作就是令当前检查的节点为pop出来的节点,这样想清楚问题也就迎刃而解了。

3.

#include<iostream>
#include<string>
#include<stack>
using namespace std;
struct node {
	int data;
	node* lchild;
	node* rchild;
};
void post_traverse(node* root);//后序遍历递归函数
int n, temp;
int main()
{
	string s;
	stack<node*> st;//建立一个包含node指针的栈
	cin >> n;
	cin >> s >> temp; //首先输入根节点
	node* root = new node;
	node* temproot = root;  //存放root副本,便于后序遍历输出
	root->data = temp;
	root->lchild = NULL;
	root->rchild = NULL;
	st.push(root);  //将根节点入栈
	while (cin >> s) {
		if (s == "Push") {
			cin >> temp;
			node* t = new node;
			t->data = temp;
			t->lchild = NULL;
			t->rchild = NULL;
			st.push(t);
			if (root->lchild == NULL) {  //当前节点没有左儿子
				root->lchild = t;
				root = root->lchild;  //将新节点添加到左儿子上并令当前节点为它的左儿子
			}
			else if (root->rchild == NULL) { //当前节点有左儿子但没有右儿子
				root->rchild = t;
				root = root->rchild;  //将新节点添加到右儿子上并令当前节点为它的右儿子
			}
		}
		else if(s=="Pop"){  //pop操作改变当前检查节点
			root = st.top();
			st.pop();
		}
	}
	post_traverse(temproot);
	return 0;
}
void post_traverse(node* root) {
	if (root == NULL) return;
	post_traverse(root->lchild);
	post_traverse(root->rchild);
	printf("%d", root->data);
	n--;
	if (n != 0) printf(" ");
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值