PAT 1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

 大概题意:给出一颗二叉树的中序遍历和后序遍历,输出该树的层次遍历。

由中序遍历和后序遍历可以确定唯一树,然后使用队列进行层次遍历。

#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<malloc.h>
#include<queue>
#include<vector>
using namespace std;

typedef struct node{
	int data;
	struct node* lchild;
	struct node* rchild;
}node;
queue<node*>q;
vector<int>ans;
int in[50], post[50], n;

node* create(int postl, int postr, int inl, int inr)
{
	if(postl > postr)
		return NULL;
	node* root;
	root = (node*)malloc(sizeof(node));
	root->data = post[postr];
	int k; // 找出根的位置
	for(k = inl; k < inr; k++)
		if(in[k] == root->data)
			break;
	root->lchild = create(postl, postl+k-inl-1, inl, k-1);
	root->rchild = create(postl+k-inl, postr-1, k+1, inr);
	return root; 
}
void bfs()
{
	while(!q.empty())
	{
		node* f = q.front();
		ans.push_back(f->data);
		q.pop();
		if(f->lchild)
			q.push(f->lchild);
		if(f->rchild) 
			q.push(f->rchild); 
	}
}




int main()
{
	while(~scanf("%d", &n))
	{
		while(!q.empty())
			q.pop();
		for(int i = 0; i < n; i++)
			scanf("%d", post+i);
		for(int i = 0; i < n; i++)
			scanf("%d", in+i);
		node *root;
		root = (node*)malloc(sizeof (node));
		root = create(0, n-1, 0, n-1);
		q.push(root);
		bfs();
		int len = ans.size();
		//cout << len << endl;
		for(int i = 0; i < len; i++)
			printf("%d%c", ans[i], i==len-1?'\n':' '); 
	}
	return 0;
	 
} 
len
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值