PAT 1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

分析:
1、很容易知道题意由中序序列和后序序列输出层序序列。

2、两种方法:一种是由中序序列和后序序列建树,然后再通过对树层序遍历来输出序列;另一种(膜拜柳婼大佬)直接中序序列和后序序列遍历得出层序序列。着重说下第二种方法,前提要知道怎么通过前序或后序序列和中序序列直接得出后序或前序序列,在此基础上按先序遍历顺序,然后用个index(初值为1)给每个根按完全二叉树的序号给每个根结点绑定值(没有子树的不影响,因为咱们用的容器,可以直接绑定有子树的序号),为什么会想到用这种方法呢?因为一棵完全二叉树有用数组存储的形式,且下标由小到大的序列也为层序遍历序列。又因为map是按键值从小到大自动排序,最后只需要遍历容器就行了。

我的代码:

建树+BFS

#include<cstdio>
#include<queue>
using namespace std;
const int maxn = 35;
int n,post[maxn],in[maxn];
struct Node
{
    int data;
    Node *left,*right;
};
Node *newNode(int data)
{
    Node *node = new Node();
    node->data = data;
    node->left = node->right = NULL;
    return node;
}
Node *create(int postl,int postr,int inl,int inr)
{
    if (postl > postr)
        return NULL;
    Node *root = newNode(post[postr]);
    int i;
    for (i = inl ;i <= inr ;i++)
    {
        if (post[postr] == in[i])
            break;
    }
    int nodeNum = i - inl;
    root->left = create(postl,postl + nodeNum - 1,inl,i-1);
    root->right = create(postl + nodeNum,postr-1,i + 1,inr);
    return root;
}
void BFSTra(Node *root)
{
    queue<Node *> q;
    q.push(root);
    while (!q.empty())
    {
        Node *temp = q.front();
        q.pop();
        printf("%d",temp->data);
        if (temp->left != NULL) q.push(temp->left);
        if (temp->right != NULL) q.push(temp->right);
        if (!q.empty())
            printf(" ");        
    }
}
int main()
{
    scanf("%d",&n);
    for (int i = 0 ;i < n ;i++)
        scanf("%d",&post[i]);
    for (int i = 0 ;i < n ;i++)
        scanf("%d",&in[i]);
    Node *root = create(0,n-1,0,n-1);
    BFSTra(root);
    return 0;
}

直接由后序序列+中序序列得出中序序列(柳婼大佬方法)

#include<cstdio>
#include<map>
using namespace std;
const int maxn = 35;
int n,post[maxn],in[maxn],cnt = 0;
map<int,int> level;
void levelTra(int postl,int postr,int inl,int inr,int index)
{
    if (postl > postr)
        return;
    level[index] = post[postr];
    int i;
    for (i = inl ;i <= inr ;i++)
    {
        if (in[i] == post[postr])
            break;
    }
    int num = i - inl;
    levelTra(postl,postl+num-1,inl,i-1,2*index);
    levelTra(postl+num,postr-1,i+1,inr,2*index+1);
}
int main()
{
    scanf("%d",&n);
    for (int i = 0 ;i < n ;i++)
        scanf("%d",&post[i]);
    for (int i = 0 ;i < n ;i++)
        scanf("%d",&in[i]);
    levelTra(0,n-1,0,n-1,1);
    for (auto it = level.begin() ;it != level.end() ;it++)
    {
        printf("%d",it->second);       
        if (cnt < level.size() - 1)
            printf(" ");
        cnt++;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

情书、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值