PAT1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

**Input Specificat
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

#include <cstring>
#include <iostream>
#include <algorithm>
#include <unordered_map>
using namespace std;
const int N=40;
int n;
int q[N];//一个队列,存储数值
int postorder[N],inorder[N];//存储后序遍历和中序遍历的数值
unordered_map <int,int> l,r;//l,r分别为左右儿子,两个int均存储数值,l<a,b>数值a的左儿子是b
unordered_map <int,int> pos;//<数值,下标>,中序遍历中某个值的下标是多少
int built(int il,int ir,int pl,int pr){
    //返回当前子树的根节点是什么
    int root=postorder[pr];//后序中最后一个为根
    ///cout<<"!"<<root<<"!";
    int k=pos[root];//根节点在中序遍历的位置
    if(il<k)    l[root]=built(il,k-1,pl,pl+(k-1-il));//左子树的个数,无论是前序还是后序均相同
    if(k<ir)    r[root]=built(k+1,ir,pl+(k-1-il)+1,pr-1);
    return root;
}
void bfs(int root){
    int hh=0,tt=0;
    q[0]=root;//队列当中的第一个为根
    while(hh<=tt){
        //当队列不为空的时候
        int t=q[hh++];//取出队头元素,但是队列当中仍然有这个元素(没删除)
        if(l.count(t)) q[++tt]=l[t];//如果t的左子树存在,将左子树存入队列当中
        if(r.count(t)) q[++tt]=r[t];
    }
    //此时队列当中的顺序即为层次遍历的顺序
    cout<<q[0];
    for(int i=1;i<n;i++) cout<<' '<<q[i];
    //这样输出最后不会多一个空格
    cout<<endl;
}
int main(){
    cin>>n;
    for(int i=0;i<n;i++) cin>>postorder[i];
    for(int i=0;i<n;i++){
        cin>>inorder[i];
        pos[inorder[i]]=i;//映射,中序遍历中数值inordre[i]的下标是i
    }
   // cout<<n<<endl;
    int root=built(0,n-1,0,n-1);//cout<<root;
    bfs(root);
    return 0;
}

PAT目录

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值