PAT 1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

 大概题意:给出一个字符串,只有0-9的数字,然后*2,判断这两个字符串用的单个字符的个数是否相同,相同的话,输出Yes,不同的输出No,之后输出*2的字符串。

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

int vis1[10], vis2[10];
string str1, str2;

int main()
{
	cin >> str1;
	memset(vis1, 0, sizeof vis1);
	memset(vis2, 0, sizeof vis2);
	str2 = str1;
	for(int i = 0; i < str1.size(); i++)	
		vis1[str1[i]-'0']++;
	int c = 0;
	for(int i = str1.size()-1; i >= 0; i--)
	{
		str2[i] = ((str1[i]-'0')*2+c) % 10 + '0';
		//cout << str2[i] << endl;
		c =  ((str1[i]-'0')*2+c) / 10;
	}
	if(c)
	{
		char cc = c + '0';
		str2 = cc + str2;
		puts("No");
		cout << str2 << endl;
		return 0; 
	} 
	for(int i = 0; i < str1.size(); i++)
		vis2[str2[i]-'0']++;
	int flag = 0;
	for(int i = 0; i < 10; i++)
		if(vis1[i] != vis2[i])
			flag = 1;
	if(flag)
	{
		puts("No");
		cout << str2 << endl;
	}
	else
	{
		puts("Yes");
		cout << str2 << endl;
	 } 
	 return 0;
 } 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值